We have noticed that some of our customers are facing issues with the newly implemented Auto-update feature for the Testsigma Agent due to issues in System Environment Variable values mainly for Windows Machines.

Issue

The agent auto update script might fail halfway and give an error like "System cannot find the path specified".


Cause

The installation location of Java Development Kit(JDK) or Java Run-time Environment(JRE) varies based on the OS architecture(32 bit or 64 bit) of the PC. Also, the presence of spaces in the directory names causes additional issues.


Before modifying the Path variable


Solution

We need to modify the System Environment variables in your system for this. Please check this article for more details on setting the Environment variables: https://support.testsigma.com/support/solutions/articles/32000023409-how-to-set-environment-variables-on-your-machine-


1. The 'Path' Environment variable contains a number of folder paths and we need to modify the value of Java Installation folder in that.

First, check the installation location of Java in your machine by going to Program Files folder in your Windows System partition(Usually C:/).

  • Case 1: Java is installed in C:\Program Files(x86)\Java\<jdk_version> folder -

    Modify the System Environment Variable named 'Path' and replace C:\Program Files(x86)\Java\<jdk_version> by C:\Progra~2\Java\<jdk_version>

  • Case 2: Java is installed in C:\Program Files\Java\<jdk_version> folder - 

    Modify the System Environment Variable named 'Path' and replace C:\Program Files\Java\<jdk_version> by C:\Progra~1\Java\<jdk_version>


2. Repeat the same procedure if JRE_HOME or JAVA_HOME Variable is present in the List of System Environment Variables.



Aftemodifying the Path variable


If you are still facing any issues with the Agent setup, please contact the Support.