Scenario:

"I am trying to run Hybrid(Local) Executions. When I start the execution, my tests stay Queued and doesn't start?"

This is a very common scenario and is mostly caused due to incorrect or incomplete configuration in Testsigma Account or the local machine.


Troubleshooting Steps:

Step 1. Check if Testsigma Agent is running or not

CHECK: Confirm that the Testsigma Agent is running by going to Configuration>Agent

If the agent is not running then you will see the following message:


If it's not, please follow the steps in the below article:
Quick setup guide - Setup TestSigma Agent on your device for Hybrid Test Execution(WIndows/Mac/Linux)


Step 3. If registered properly, check the Executions tab to see if Agent is outdated

CHECK: Go to the Testsigma Agent > Executions page and confirm there's no Outdated Agent message.


Step 4. If there's no 'Agent outdated' message, check if there's a mismatch in IP Address or Port

CHECK: Confirm that the IP Address, Port in Testsigma Agent Dashboard(first image) is same as the IP Address, Port for the System added to Testsigma Account under Configuration > Systems as shown below:

Step 6. If there queued execution is missing in the Executions tab, check for Exceptions in Testsigma Agent CLI Window

Check: Make sure that there are no exceptions in the Testsigma Agent window as shown below:


If there are exceptions, it would look like shown below:

If all of the above steps are checked and the issue still persists, please get in touch with Testsigma Support using the Instant chat option on the bottom left corner or mail us at support@testsigma.com